Заявка в АРК Технолоджис
(812)974.06.35
О компании archive.arctech.ru

Mikrotik: готовим к применению

Mikrotik: готовим к применению

Данная заметка описывает типовую подготовку Микротика к роли рутера в небольшой корпоративной сети.

I. В качестве консоли для микротика используем Линукс. Если вы планируете использовать winbox - ваше право. Тогда подготовьте  виртуальный Линукс, заточенный специально под работу c wine. И winbox.

1. Полагаем, что Линукс к сети с микротиком подключен через интерфейс eth0:

export MKT_IP=192.168.88.1 ; ifconfig eth0:0 192.168.88.10/24 up && ping $MKT_IP -с 5  

2. Далее подключаемся к микротику.  Через winbox или по ssh. В последнем случае советуем предварительно внести в начало /etc/ssh/ssh_config:

  Hostname 192.168.88.1

  Port 22

  PubkeyAcceptedKeyTypes +ssh-dss

  HostKeyAlgorithms=+ssh-dss

  KexAlgorithms diffie-hellman-group14-sha1

  Ciphers aes256-cbc

Эти изменения гарантируют, что

а) не будет проблем с подключением с debian stretch, ubuntu xenial, ...

б) удастся подключиться даже к микротику с версией прошивки 5.0+.

Ну и:

ssh admin@${MKT_IP}  

Можно не править /etc/ssh, тогда

ssh -c 3des-cbc -o "PubkeyAcceptedKeyTypes +ssh-dss" \

    -o "KexAlgorithms diffie-hellman-group1-sha1" \

  -o "HostKeyAlgorithms=+ssh-dss" admin@${MKT_IP} 

II. Начнем с обновления. Практика показала, что микротик с прошивкой "из магазина" может капризничать.  Да и функций может оказаться побольше после прошивки. За те же деньги :)

1. Через winbox обновляемся так:

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

И в открывшемся окне:  

Запускаем upgrade прошивки

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Увидим статус текущей прошивки:

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

2. Через ssh upgrade проще ;):

/system package update

check-for-updates 

          channel: current

          current-version: 6.35.4

           latest-version: 6.41

           status: New version is available

install 

III.  Подгягиваем безопасность.

1. Через winbox воспользуемся вкладкой System->Users. Далее все очевидно.

2. Через ssh

а) добавляем  нового суперпользователя, с другим именем (root) и устанавливаем ему пароль:

/user add name=root group=full

/user set root password=<new_passwd> 

б) отключаем права на запись у дефолтного admin-а и назначаем ему пароль:

/user set admin password=<new_passwd> ; user set admin group=read

в) меняем дефолтные порты winbox и ssh:

/ip service edit ssh port=22222 ; /ip service edit winbox port=58555

IV. Устанавливаем NTP-клиента и NTP-сервер

Данные демоны/службы не устанавливаются по умолчанию. Их необходимо скачать как extra packages отсюда: https://mikrotik.com/download.

ВАЖНО! Пакеты должны соотвествовать "железной" архитектуре вашего микротика! 

Распаковывайте. После чего копируйте на микротик файл ntp-<version>-<hdware>.npk.

Перезагрузите микротик. Vous a la, во вкладке System появятся NTP-server и NTP-clent:

Mikrotik: NTP client + server

 

 

 

 

 

 

 

 

 

 

 

 

 

Вернуться в список статей